Close

Page 3 of 3 FirstFirst 123
Results 51 to 57 of 57
  1. #51
    Join Date
    Jul 2011
    Posts
    73
    Rep Points
    222.8
    Mentioned
    2 Post(s)
    Rep Power
    3


    Reputation: Yes | No
    Click here to enlarge Originally Posted by JRCART Click here to enlarge
    Lol, I just watched video, on that pass car popped into neutral, it felt like something broke with the sudden lose of power and the way it back fired so I shut it down and pulled off. I have had the car pop into neutral a couple times, Weistec knew this was a problem and was developing urethane mounts which were installed on my car last week and I was going to test today. I am planning on going to Union Groves test and tune this Wednesday weather permitting. Car is not broken nor was it broken and I can post a video of the car running later today when I get home if anyone doubts me.
    That's very good news! We all look forward to great results in the coming months.

  2. #52
    Join Date
    Oct 2010
    Location
    Northport NY
    Posts
    1,550
    Rep Points
    736.0
    Mentioned
    23 Post(s)
    Rep Power
    8


    Reputation: Yes | No
    Glad to hear it was a little glitch and not a big problem

    Click here to enlarge Originally Posted by JRCART Click here to enlarge
    Lol, I just watched video, on that pass car popped into neutral, it felt like something broke with the sudden lose of power and the way it back fired so I shut it down and pulled off. I have had the car pop into neutral a couple times, Weistec knew this was a problem and was developing urethane mounts which were installed on my car last week and I was going to test today. I am planning on going to Union Groves test and tune this Wednesday weather permitting. Car is not broken nor was it broken and I can post a video of the car running later today when I get home if anyone doubts me.
    Click here to enlarge
    Drives: Basically a pretty bad ass f250 lifted with 24" wheels! Dpf delete 4" exhaust h&s tuner and intake..

  3. #53
    Join Date
    Aug 2012
    Posts
    164
    Rep Points
    118.3
    Mentioned
    4 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    Click here to enlarge Originally Posted by JRCART Click here to enlarge
    Ya, to be honest the thing I am most happy with is the transmission, it worked flawlessly when I shifted it right. The trans was the one question mark I still had. I posted slip because it's a personal best with this car. Trust me I am more embarrassed with my performance today than proud. I would have gone faster if I figured out the shifting earlier but I think I have it all figured out now.
    @JRCART

    I really don't see how you are ashamed. I know that I would be proud. Your running a 10.6 at a 3000+ DA with shifting and traction issues. Your car is a total beast. Not many cars could do that @96F. My buddy's modded corvette ZR1 runs low 10's in the winter. He ran it last week and tapped a best of 11.8 . At one run he even tapped 12. I wanted to ask you sir, and I assume you are running catless, what type of Oil are you using with all that power? Are you still using Mobile 1 ?
    O

  4. #54
    Join Date
    Dec 2010
    Location
    PNW
    Posts
    139
    Rep Points
    288.2
    Mentioned
    2 Post(s)
    Rep Power
    3


    Reputation: Yes | No
    Click here to enlarge Originally Posted by Fast Lane Click here to enlarge
    @JRCART

    I really don't see how you are ashamed. I know that I would be proud. Your running a 10.6 at a 3000+ DA with shifting and traction issues. Your car is a total beast. Not many cars could do that @96F. My buddy's modded corvette ZR1 runs low 10's in the winter. He ran it last week and tapped a best of 11.8 . At one run he even tapped 12. I wanted to ask you sir, and I assume you are running catless, what type of Oil are you using with all that power? Are you still using Mobile 1 ?
    O
    Good question. I was thinking of using motul 300v 5w40....with obviously much shorter change intervals.

  5. #55
    Join Date
    Apr 2011
    Posts
    1,369
    Rep Points
    794.0
    Mentioned
    51 Post(s)
    Rep Power
    8


    Reputation: Yes | No
    Unless Jimmy has switched, we are using Royal Purple.

    Looking forward to some updates from Jim though as I won't be running until November sometime and I want a new benchmark to shoot for Click here to enlarge
    Click here to enlarge

    I will quit being rude if you quit being stupid.

  6. #56
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,219
    Rep Points
    31,317.1
    Mentioned
    2056 Post(s)
    Rep Power
    314


    Reputation: Yes | No
    So the trans mounts cause it to pop into netural?
    Stage 2 or 2.5 E9X M3 S65 V8 supercharger kit for sale: http://www.boostaddict.com/showthrea...r-kit-for-sale

  7. #57
    Join Date
    Oct 2010
    Location
    Northport NY
    Posts
    1,550
    Rep Points
    736.0
    Mentioned
    23 Post(s)
    Rep Power
    8


    Reputation: Yes | No
    Thats horrible


    Click here to enlarge Originally Posted by Fast Lane Click here to enlarge
    @JRCART

    I really don't see how you are ashamed. I know that I would be proud. Your running a 10.6 at a 3000+ DA with shifting and traction issues. Your car is a total beast. Not many cars could do that @96F. My buddy's modded corvette ZR1 runs low 10's in the winter. He ran it last week and tapped a best of 11.8 . At one run he even tapped 12. I wanted to ask you sir, and I assume you are running catless, what type of Oil are you using with all that power? Are you still using Mobile 1 ?
    O
    Click here to enlarge
    Drives: Basically a pretty bad ass f250 lifted with 24" wheels! Dpf delete 4" exhaust h&s tuner and intake..

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •